平台开发中,欢迎参与测试。你可以在 QQ群:1046115671 中与我们交流,或是直接在社区发帖

健康检查与故障排除

帮助改进此插件的 简体中文 翻译~ 同时,你可以通过安装 WP-China-Yes 插件,并切换应用市场为“LitePress 应用市场”来接收翻译推送。

此插件将对您的 WordPress 安装进行一系列检查,以检测常见的配置错误和已知问题,也允许插件和主题作者添加自己的检查项。

调试部分,允许您收集有关您的 WordPress 和服务器配置的信息,这样您就可以简单地将其分享给主题、插件或官方 WordPress.org 支持论坛的支持代表。

故障排除允许您有一个干净的 WordPress 会话,该会话中所有的插件都会被禁用,并使用默认主题,但只对您 [当前用户] 有效,直到您将其禁用或注销。

工具部分可以让您检查 WordPress 的核心文件是否被篡改,邮件是否可以发送,以及您的插件是否兼容将来的 PHP 更新版本。

关于如何有效地使用健康检查插件的更多例子,请查看WordPress.org 支持团队手册页面关于此插件

欢迎在WordPress.org 支持论坛GitHub 项目页面,或通过Slack中的#forums#core-site-health频道进行反馈。

屏幕截图

v1.4.5

  • 修复 WordPress 5.5 前端的故障排除模式的出错问题。

v1.4.4

  • 修复在仪表盘上使用故障排除模式时的隐藏 JavaScript 警告。
  • 修复插件和主题列表在仪表盘上的故障排除模式下保持隐藏的问题。

v1.4.3

  • 与 WordPress 5.4 兼容

v1.4.2

  • 修复在调试部分缺失的回环请求标头

v1.4.1

  • 修复了对各种 MariaDB 安装的 SQL 版本检查问题。
  • 修复首次使用的用户在没有站点健康历史记录的情况下在日志文件中会生成警告的问题。
  • 为新的 PHP 兼容性工具添加了缺少的翻译函数。

v1.4.0

  • 修复在故障排除模式下启用健康检查插件时,查看站点健康页面出现的错误。
  • 修复数据库版本检查方式不一致的问题。
  • 修复 Windows 系统中如果有修改核心文件的情况下的文件对比视图。
  • 修复一些高级插件无法在故障排除模式下启用的错误。
  • 改进了旧版浏览器的样式。
  • 改进了 PHP 模块检查已允许进行持续检查。应有助于一些 edge 环境下的测试。
  • 改进了核心文件完整性检查。
  • 改进了 WP_cron 的测试,现在对于那些在 WordPress 之外运行 “实际 cron “的用户,也已经可以正常运行。
  • 改进了 htaccess 规则测试,使其仅在使用支持这些规则的 Apache 服务器时运行。
  • 修改站点健康分级指标。
  • 修改了字符串,使其更加清晰。
  • 在调试信息中添加了服务器标头的信息。
  • 为 WordPress 5.2 的核心功能添加了 polyfills,使其能够适用于较老站点。
  • 在插件概述中添加了指向站点健康页的链接。
  • 为插件添加了一个自定义功能,view_site_health_checks
  • 在调试界面增加了对父 / 子主题输出的支持。
  • 在调试信息中添加了系统用户的信息。
  • 为时区本地化添加了站点健康测试。
  • mbstringJSON作为要求添加到 PHP 扩展列表中。
  • 在故障排除仪表盘小工具的插件 / 主题列表中添加了一个缺失的切换。
  • 增加了批量操作,以便在故障排除时启用或禁用插件,或启用故障排除模式。
  • 在 “工具” 部分添加了插件兼容性检查工具。
  • 添加了一个仪表盘小工具,以便在登录后可以一目了然地显示您的站点健康状态。
  • 增加了站点健康测试结果的筛选。
  • 增加了对 WP-CLI 的支持,您现在可以运行wp health-check status查看测试列表及其状态。
  • 将兼容性函数从主文件中移出,移到compat.php中,这样就可有条件地对其进行加载。
  • 在故障排除模式下,禁用 WordPress 中的致命错误(WSOD)保护。

I am unable to access my site after enabling troubleshooting

Answer:

If you should find your self stuck in Troubleshooting Mode for any reason, you can easily disable it by clearing your cookies.

Are you unfamiliar with how to clear your cookies? No worries, you may also close all your browser windows, or perform a computer restart and it will clear this specific cookie automatically.

The PHP compatibility says this plugin only work with PHP version X?

Answer:

The plugin is made to be a support tool for as many users as possible, this means it needs code that is written for older sites as well.

Tools that check for PHP compatibility do not know how to separate this code from the real code, so it will give a false positive response.

At this time, the plugin has been tested with every version of PHP from 5.2 through 7.3, and works with all of these.

评价

目前还没有评价

成为第一个“健康检查与故障排除” 的评价者